MyDMS

Wünschenswertes und allgemeine Diskussionen rund um das Thema AvERP Groupware und zur Synchronisierung mit AvERP

Moderator: SYNERPY

Antworten
Gast

MyDMS

Beitrag von Gast » Mo Dez 17, 2007 4:50 pm

Hallo zusammen!

Hat hier jemand schon Erfahrungen bei der Einrichtung gesammelt? Hier klappt es mit kleinen Dateien im Grunde einwandfrei, bloß bei größeren ist es nicht möglich diese hochzuladen, aber ich denke das ist dann ja entweder ne Einstellungssache von php oder MySQL wo da die Max-Grenze ist.

Worum es hier eigentlich geht ist aber, dass ich Probleme mit der Vorschauansicht der Dokumente habe. Das einfach herunterladen ist kein Problem, nur die Ansicht zickt, weil er dafür wohl das Dokument temporär in einen Ordner zur Ansicht verfrachtet, der dafür separat immer erstellt wird. Und immer beim Aufruf der Online Ansicht sagt mir dann der Server immer eine 404 für "/averp-groupware/mydms/op/viewonline/../../datei...."
Bin schon dabei im Forum des Entwicklers hier zu stöbern, aber bisher ohne das mir etwas weiterhalf. Werd morgen nochmal intensiv da schauen, aber vllt. hat ja jemand hier das gleiche Problem schon gelöst, bevor ich mir die Augen wund suche :wink:

eugen
Beiträge: 26
Registriert: Mo Nov 19, 2007 12:41 pm

Beitrag von eugen » Di Dez 18, 2007 8:46 am

ab welcher größe hast du denn Probleme? meine das in der PHP.ini irgendwo ein begrenzung für den Upload steht. Bin gleich in der Firma und kann dir dann die genaue stelle sagen.

MfG

Gast

Beitrag von Gast » Di Dez 18, 2007 8:49 am

genaue größe weiß ich so nicht, ist mir bis jetzt so nebenbei aufgefallen, schlimmer fand ich, dass das mydms bei mir so störrisch ist. wie eben die onlinebetrachtung z.B.

eugen
Beiträge: 26
Registriert: Mo Nov 19, 2007 12:41 pm

Beitrag von eugen » Di Dez 18, 2007 9:28 am

so, erstmal die Dateigröße:

Code: Alles auswählen

; Maximum size of POST data that PHP will accept.
post_max_size = 8M
hier kannst du dann demenstprechend den Wert hochsetzen. Schau mir gleich mal an ob ich bei mir eine Vorschau habe.

eugen
Beiträge: 26
Registriert: Mo Nov 19, 2007 12:41 pm

Beitrag von eugen » Di Dez 18, 2007 9:37 am

mit vorschau meinst du "online ansicht" ? bei mir geht das Prima. Ich habe hier ein PDF File hochgeladen das dann durch die online ansicht als neues Fenster geöffnet wird. Du hast wenn ich das richtig gesehen habe ein Linux -System oder? hast du die Rechte der Ordner und unterordner richtig gesetzt? ich habe bei meinem System mit

Code: Alles auswählen

chgrp -R www-data GORUPWAREORDNER 
chown  -R www-data GORUPWAREORDNER
alle Rechte dem Apache Server gegeben. Fehlt das evtl.?

Gast

Beitrag von Gast » Di Dez 18, 2007 10:52 am

ja genau das meinte ich, also die online ansicht. irgendwie spinnt das alles hier total... wenn ich versuche ein pdf online zu betrachten erhalte ich mal die fehlermeldung "invalid documentid", dann mal wieder wenn es in nem unterordner liegt "invalid folderid", gehe ich dann wieder auf den root-folder sehe ich den angelegten unterordner auf einmal 4-5 mal, gestern habe ich eine date hochgeladen, die auf einmal doppelt vorhanden war, setze ich die erwähnten werte für die max. dateigröße mal ausreichend hoch, dann konnte ich plötzlich eine datei von ca. 240mb nicht mehr hochladen, danach ging nichts mehr, ich konnte gar keine datei mehr hochladen, jedes mal bekam ich dann eine "invalid documentid". ein anderes mal kann ich dann beim online betrachten angeblich nur die op.ViewOnline.php herunterladen, anstatt das die ausgeführt wird.
Das merkwürdige an all dem ist ja, dass die Fehler nicht unbedingt reproduzierbar sind, sondern scheinbar willkürlich auftreten. Das Èinzige was reproduzierbar ist, ist dass das Online betrachten gar nicht geht :wink:
Internet Explorer und Firefox produzieren teils auch unterschiedliche Fehler. So war ich mit dem FF angemeldet, wollte mich dann auch noch mit dem IE anmelden, Fehler (leider hab ich die Meldung nicht mehr zur Hand), dann beim FF explizit abgemeldet, selbe Fehlermeldung, dann versuch wieder mit dem FF anzumelden, andere Fehlermeldung aber konnte mich auch nicht anmelden. Dann wieder mit dem IE versucht und plötzlich ging es. Grad dann mit dem IE Online betrachten probiert, "Invalid Documentid", danach nur am unteren Bildschirmrand das IE-Symbol für "Fehler auf der Seite" klickte dann mal zufällig auf "Zugriffsrechte" und wieder zurück auf den Inhalt des Ordners, klicke auf das PDF, sage online betrachten und ES GEHT!

Aber ich wette, dass ist jetzt auch nur zufall, wenn ich es noch ein paar mal probiere geht es wieder nicht.

So am Rande: Das System ist Ubuntu und Apache läuft mit dem Benutzer und der gleichnamigen Gruppe apache. Die Rechte für htdocs sind mittlerweile samt Unterordnern auf apache:apache gestellt, mit den Berechtigungen 755.
Hier scheint echt einiges bei mir im Argen zu sein... hoffe, dass das mit einer neuen Testinstallation demnächst besser ist, aber erstmal fummel ich hier noch rum :twisted:

Gast

Beitrag von Gast » Di Dez 18, 2007 11:13 am

da ich meine beiträge ja plötzlich doch nicht mehr editieren kann nun noch eine neue nachricht:

also im ie ist es in so weit reproduzierbar als das ich ein pdf hochlade, zu der datei gehe und sie online betrachten will, dann kommt in einem neuen fenster "invalid documentid", schließe ich das fenster und klicke wieder auf root-folder, bekomme ich das symbol für "fehler auf der seite" und muss erst im nav-menü links auf etwas klicken, am besten ja content, wähle ich dort nun die soeben hochgeladene datei, öffnet sich ja das detailfenster de´s dokuments, dort klicke ich dann auf online betrachten und et lüppt.
fehler scheint unabhängig vom browser zu sein... :?:

eugen
Beiträge: 26
Registriert: Mo Nov 19, 2007 12:41 pm

Beitrag von eugen » Di Dez 18, 2007 12:01 pm

... hast du das importscript richtig angepasst? ich meine mich zu entsinnen das ich ähnliche Problem hatte bis ich das importscript komplett angepasst habe.

phpgw_mydms_ACLs
phpgw_mydms_DocumentContent
phpgw_mydms_Documents
phpgw_mydms_Folders
phpgw_mydms_GroupMembers
phpgw_mydms_Groups
phpgw_mydms_Notify
phpgw_mydms_DocumentLinks
phpgw_mydms_Sessions
phpgw_mydms_UserImages
phpgw_mydms_Users
phpgw_mydms_KeywordCategories
phpgw_mydms_Keywords

ich musste also all die oben genannten Punkte variablen im Script suchen und wegen hinsichtlich der Groß/kleinschreibung anpassen. Jetzt läuft bei mir alles Prima, jedenfalls beim DMS ;)

Gast

Beitrag von Gast » Di Dez 18, 2007 1:21 pm

hm habe ich in den anderen threads schonmal geschrieben, dass es da probleme gibt, weil das script nur kleingeschriebenes anlegt, aber die groupware manches gerne mit großbuchstaben hätte.
Habe ich hier schon angemerkt und hier nen weg aufgezeigt, wie man die my.cnf anpassen muss, damit mysql nicht mehr case sensitive arbeitet. ich dachte damit hätte ich alle probleme behoben. werde es aber mal testen die datenbank zu sichern, das script nochmal anzupassen und mysql doch wieder case-sensitive zu machen.

eugen
Beiträge: 26
Registriert: Mo Nov 19, 2007 12:41 pm

Beitrag von eugen » Di Dez 18, 2007 1:31 pm

ja, den "trick" mit der my.cnf habe ich gesehen, war bei mir aber zu spät da ich das alles schon händisch umgeschrieben hatte und da es auch ging, getreu dem motto "never touch a running system" habe ich es auch dabei belassen. Klappts denn nun?

Gast

Beitrag von Gast » Di Dez 18, 2007 2:02 pm

nope. genau das gleiche "phänomen". also ich habe nun mal die groß-/kleinschreibung im script wie vorgeschlagen angepasst, das case-sensitive aus der my.cnf wieder herausgenommen, die averp-groupware table nochmal gedroped und mit dem script nochmal eingespielt. kein unterschied, selbes verhalten

Gast

Beitrag von Gast » Di Dez 18, 2007 3:00 pm

Schnell Kommando zurück!
Eugen klappt bei dir mittlerweile der Abgleich?
Weil mir ist grad aufgefallen, wenn man das Skript mit deinen Werten anpasst und MySQL wieder Case-Sensitive schaltet, dann sagt er ersteinmal ohne das überhaupt etwas übertragen wird, dass er die Tabellen A_AGW_DBSYNC und A_AGW_DBSYNC_PZUORD nicht kennt. Ich dachte kein Problem, also mal eben in phpMySQL die Groß-/Kleinschreibung angepasst und dann war die Meldung weg. Habe dann einen Mitarbeiter angelegt und dann kam eine neue Meldung und zwar das er dann wiederum die a_agw_dbsync_pzuord nicht finden kann.
Ich führe das nun mal auf eine andere Stelle im Skript zurück, wo eben noch mit dem kleingeschriebenen gearbeitet wird und an anderer Stelle wieder mit großgeschriebenem. Ziemlich ärgerlich, vorallem wenn man nicht immer das Skript anpassen und wieder testen will.
Ich würde also wirklich weiterhin bei MySQL den Eintrag

Code: Alles auswählen

lower_case_table_names=1
aktivieren um damit den Problemen irgendwie aus dem Weg zu gehen.

Ich würd mir wünschen, wenn das Skript mit der nächsten Version so angepasst ist, dass es bei Table-, Procedure-, etc.-Namen nur auf Kleinschreibung basiert um dem aus dem Weg zu gehen.

eugen
Beiträge: 26
Registriert: Mo Nov 19, 2007 12:41 pm

Beitrag von eugen » Mi Dez 19, 2007 11:18 am

also bei mir ging das ohne Probleme durch. Habe jetzt den Befehl in meine my.conf eingefügt (unter MySqld) und den Mysql Server neu gestartet. Scheint aber ohne wirkungs zu sein, bekomme wieder fehlermeldungen beim Zugriff auf MyDMS. Sehe aber keinen Fehler in meiner conf...

Hier meine my.conf:

Code: Alles auswählen

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port		= 3306
socket		= /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket		= /var/run/mysqld/mysqld.sock
nice		= 0

[mysqld]
#
# * Basic Settings
#
user		= mysql
pid-file	= /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
basedir		= /usr
datadir = /var/lib/mysql
tmpdir		= /tmp
language	= /usr/share/mysql/english
skip-external-locking
lower_case_table_names=1
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords	= 1
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
#
# * Fine Tuning
#
key_buffer		= 16M
max_allowed_packet	= 16M
thread_stack		= 128K
#
# * Query Cache Configuration
#
query_cache_limit	= 1048576
query_cache_size        = 16777216
query_cache_type        = 1
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log		= /var/log/mysql.log
#log		= /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log-slow-queries	= /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication.
#server-id		= 1
log-bin			= /xxxxxx/mysql-bin.log
expire-logs-days	= 20
max_binlog_size         = 104857600

#binlog-do-db		= include_database_name
#binlog-ignore-db	= include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet	= 16M

[mysql]
#no-auto-rehash	# faster start of mysql but no tab completition

[isamchk]
key_buffer		= 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the ndbd storage daemons,
# not from the ndb_mgmd management daemon.
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1

Gast

Beitrag von Gast » Mi Dez 19, 2007 1:36 pm

hm sieht irgendwie ja nicht danach aus, als hättest du mysql über xampp installiert :wink:
aber eben mit der einstellung wegen case-sensitive, dem neustart des dienstes und dem erneuten (!) einspielen der datenbank, also des mysql-skriptes im original sollte es doch irgendwie eigentlich klappen. zumindest war hier so mein vorgehen.
welche fehler hast du denn beim zugriff aufs dms :?:

eugen
Beiträge: 26
Registriert: Mo Nov 19, 2007 12:41 pm

Beitrag von eugen » Mi Dez 19, 2007 1:53 pm

ja, ich habe den Apache Server schon länger laufen, hatte anfang des Jahres mit LX-Office probiert, ist zwar nett, aber auch nicht mehr. Augrund dessen kam für mich das XAMPP Packet nicht in frage.

Ich habe die config angepasst, den MYSQL Server neugestartet, die alte Datenbank gelöscht und dann eine neue erstellt. In dieser habe ich dann das script per MYSQL Administrator importiert.

Der Fehler ist ja bekannt:

Code: Alles auswählen

Database error: Invalid SQL: SELECT * FROM phpgw_mydms_Folders WHERE id = 1
mysql Error: 1146 (Table 'averp-groupware.phpgw_mydms_Folders' doesn't exist)

File: /usr/share/egroupware/mydms/inc/inc.DBAccess.php
Line: 36
Function: databaseaccess::getresultarray / getfolder(1)

Session halted.
Also langsam bin ich soweit das ich evtl. doch meinen Apache sichere und dann alles neu aufsetze aber dann mit dem XAMPP Packet :(

Antworten