ERLEDIGT Verbindungsaufbau dauert plötzlich 80 Sekunden

Einsatz von AvERP mit Linux als Server- und/oder Anwendungs-OS

Moderator: SYNERPY

Antworten
Gast

ERLEDIGT Verbindungsaufbau dauert plötzlich 80 Sekunden

Beitrag von Gast » Di Jun 01, 2010 9:59 am

Hallo zusammen,

seit dem Wochenende plagt mich folgendes Problem:

Der Verbindugnsaufbau zu unserer Kopie der Produktivdatenbank auf unserem Testserver dauert regelmäßig >1min. Die Geschwindigkeit wenn man erst mal auf der Datenbank angemeldet ist scheint im Vergleich zur Vorwoche auch etwas abgenommen zu haben.
Auf unserem Produktivserver tritt mit der selben Datenbank das Problem nicht auf und auf einem noch langsameren Server zum Test dauerte der Verbindungsaufbau auch nur ein paar Sekunden.

Am Wochende habe ich jedoch ca. 42.000 Dokumente in Word- und Excel auf diesen Server kopiert, auf den nun die ganze Firma per Samba zugreift. Das Gros der Clients arbeitete zuvor aber auch schon über Samba auf diesem Server, zugenommen hat somit nur die Zahl der geöffneten Verbindungen und die Zahl der absoluten Dateien auf dem Server.
Darüber hinaus ist der Server seit dem Wochenende auch unter einem 2. Namen der über DNS aufgelöst wird erreichbar und der nmbd-Dienst von Samba hat neben seinem normalen Netzwerknamen noch ein Alias dazu bekommen.

Somit war meine Idee schon, dass es vllt. Probleme mit der Zahl der geöffneten Verbindungen / Dateien gibt, aber heute morgen gegen 06:40Uhr waren erst sehr wenige Personen zu dem Server verbunden und es änderte rein gar nichts an der Geschwindigkeit.

Bisher habe ich folgendes ohne Erfolg versucht:
-Kontrolle auf Pakete die seit dem Wochenende aktualisiert wurden
-Neustart des openbsd-inetd Dienstes
-Installation des Firebird2.1.3 aus den Paketquellen
-Verbindungsaufbau direkt an der Konsole des Servers über isql
-Verbindungsaufbau direkt über IP-Adresse des Servers

Nichts brachte eine Verbesserung, die Wartezeit war immer gleich. Es lässt sich während der Wartezeit weder eine Festplattenaktivität noch eine Prozessorauslastung erkennen. Die Logfiles von Firebird und Syslog zeigen rein gar nichts interessantes hierzu an

Der Server läuft unter Ubuntu 9.10 32-Bit mit dem Kernel 2.6.32-22-generic-pae, verfügt über 4 Xeon-Kerne à 2.6GHZ und insg. 3GB RAM. 4 SATA Platten bilden ein Raid5 mit 2.67GB Platz und arbeiten komplett mit Ext4. Alle Daten liegen auf einer Partition.

Am System hat sich ausser dem o.g. am Wochenende nichts geändert...
Täglich führen wir auch ein Backup unserer Produktivdatenbank und ein Restore auf eben diesen Server durch, seit Samstagabend dauert das Restore plötzlich nicht mehr 1:14 Std. im Schnitt sondern 1:18 Std. ohne das sich die Daten überdurchschnittlich vermehrt hätten (insbesondere nicht von Fr. auf Sa.).

Hat jemand schon mal ähnliche Erfahrungen gemacht, oder hat er andere plausible Erklärungen?

Was mir grad nochmal aufgefallen ist: Es macht keinen Unterschied ob ich mich mit isql lokal zur employee.fdb verbinde, oder ich unsere Produktivdatenbank nehme - die Verbindung kommt nach genau 80 Sekunden in beiden Fällen zustande.
Verbinde ich mit AvERP-Start dann dauert es nach Auswahl der Verbindung fast genau 60 Sekunden bis das Fenster "Datenbankverbindung wird hergestellt" erscheint und nach weiteren ca. 60 Sekunden lädt der Fortschrittsbalken und AvERP erscheint binnen 2 Sekunden.
Aber was bitte für ein Timeout ist das denn wohl und wo kann der plötzlich herkommen... wenn es denn ein TimeOut ist?!

[Edit]
Wenn ich auf dem Server mittels ISQL eine neue Datenbank erstelle, so dauert das exakt 180 Sekunden. Schreit also auch nach einem TimeOut wie ich finde.
[/Edit]

[Edit2]
Hat sich auf mysteriöse Weise nach einem ganzen Neustart des Servers erledigt.
[Edit2]

Antworten